Completed
Schedule Maintenance Feb 14th, 2024 22:00pm EST - 23:00pm EST

Status
Resolved after about 1 hour
Started
February 15, 2024 at 3:00 AM
Completed
February 15, 2024 at 4:00 AM
Affects
Website
App
  • Completed
    February 15, 2024 at 4:00 AM
    Completed
    February 15, 2024 at 4:00 AM
    Maintenance has completed successfully
  • In progress
    February 15, 2024 at 3:00 AM
    In progress
    February 15, 2024 at 3:00 AM
    Maintenance is now in progress
  • Planned
    February 15, 2024 at 3:00 AM
    Planned
    February 15, 2024 at 3:00 AM

    We are planning scheduled maintenance for Feb 14th, 2024 22:00pm EST - 23:00pm EST.

    All services will be unavailable at this time.