Started almost 3 years agoOctober 20, 2023Lasted about 5 hoursOctober 20, 20236:4211:49 PMUTC
Affected
Website
Degraded performance from 6:42 PM to 11:49 PM
App
Degraded performance from 6:42 PM to 11:49 PM
Updates
Resolved
UTC
Resolved
UTC
This incident has been resolved and service has been fully restored.
Identified
UTC
Identified
UTC
We've identified an issue with our dns and caching provider that is leading to slower than application start times. We are currently investigating this incident.